Debian: Bad archive mirror при установке старых версий дистрибутива

  • 10.08.2023
  • 1 995
  • 0
  • 12.08.2023
  • 8
  • 8
  • 0
Debian: Bad archive mirror при установке старых версий дистрибутива

Описание и решение проблемы

При установке старых версий Debian, в процессе выборе зеркала с обновлениями для пакетного менеджера, можно получить ошибку о том, что оно не работает.

Bad archive mirror

An error has been detected while trying to use the specified Debian archive mirror.

Possible reasons for the error are: incorrect mirror specified; mirror is not available (possibly due to an unreliable network connection); mirror is broken (for example because an invalid Release file was found); mirror does not support the correct Debian version.

Additional details may be available in /var/log/syslog or on virtual console 4.

Please check the specified mirror or try a different one.


Для исправления ситуации следует указать зеркало вручную, поскольку на основных зеркалах пакетов для старых версий нет. Для этого нужно пролистать список стран в самый верх, где будет пункт "enter information manually".


Здесь следует ввести адрес archive.debian.org, или иной другой из этого списка.


В следующем окне следует оставить значение /debian/.


В процессе проверки зеркала возникнет ошибка, что нет возможности получить доступ к репозиторию с обновлениями безопасности. Это "нормально", поскольку для старых версий Debian они больше не выпускаются.

После пропуска данной ошибки, установка должна продолжиться.

Была ли эта статья Вам полезна?

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Напоминаем Вам, что Ваше сообщение будет опубликовано только после проверки администратором сайта. Обычно это занимает 1-2 рабочих дня.